Updox Fax

Incident Report for Updox-Partners

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 18:30 EDT

Monitoring

Our third-party fax vendor has communicated that the issue is resolved. We will continue to monitor. If there are no additional occurrences, the status of this incident will be moved to resolved in 30 minutes
Posted Jul 08, 2026 - 18:04 EDT

Update

Our third-party fax vendor has determined the cause of the disruption of service and is working on a resolution. We will continue to post updates as they are available.
Posted Jul 08, 2026 - 17:02 EDT

Update

Our team is in communication with our third-party fax vendor and they continue to investigate the issue. We will continue to provide updates as they are available.
Posted Jul 08, 2026 - 16:09 EDT

Identified

Updox is aware that our third-party fax vendor has reported a disruption of service. Some customers may experience delays in sending and receiving faxes. We are partnering with our fax vendor and will continue to provide updates as they are available.
Posted Jul 08, 2026 - 15:17 EDT
This incident affected: Faxing.