Updox Address Book - Patient and Contact Search
Incident Report for Updox-Partners
Resolved
A fix has been implemented and this incident is resolved. We sincerely apologize for any impact this caused to you and your business.
If you require further assistance, please contact partnersupport@updox.com.
Posted Nov 08, 2023 - 13:13 EST
Identified
Our technical operations team has identified an issue impacting the ability to find patients and contacts in Updox. We are working to restore functionality as quickly as possible.
We sincerely apologize for any inconvenience this causes to your business and will keep you updated on our progress.
Posted Nov 08, 2023 - 11:08 EST
This incident affected: Interface / Connection to Updox (Web User Interface) and Faxing, Import to EHR.