System Unavailable

Incident Report for Updox-Partners

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 11:29 EDT

Monitoring

The fax delay is resolved and all systems are observed to be operational. The team continues to monitor performance and networking prior to marking the incident resolved. We appreciate your patience and understanding.
Posted Jun 02, 2025 - 19:06 EDT
This incident affected: Faxing and Interface / Connection to Updox (Patient Portal).