Updox Ticket System. Unable to reply to submitted tickets
Incident Report for Updox-Partners
Resolved
We are able to email out now. We will be working tickets in the order received.
Posted Mar 20, 2024 - 13:04 EDT
Investigating
The Partner support team is currently unable to reply to tickets submitted to our partnersupport@updox.com address. This is also affecting support@updox.com. We are recieving emails and working tickets however we are unable to reply currently. Our Business Operations team is working to restore the functionality. We will reply to submitted tickets once functionality is restored.
Posted Mar 20, 2024 - 11:44 EDT
This incident affected: Updox Corporate Office.