Cloudflare (internet infrastructure) has communicated that they are continuing to monitor the issue. We may continue to experience intermittent issues as systems update across the internet. We will continue to monitor to ensure all systems are back to normal across the day.
Posted Nov 18, 2025 - 11:09 EST
Identified
Cloudflare (internet infrastructure) is experiencing a global network outage. This issue may be impacting access to parts of the system. Our system does not leverage Cloudflare directly but many of our integrated third parties do and are showing intermittent impact. Due to this, functionality that relies on third parties may have intermittent errors and/or delays. This is also preventing our support team from accessing certain tools used to support our customers. We are monitoring the situation closely and will update this message with the known list of impacted areas.
Posted Nov 18, 2025 - 08:57 EST
This incident affected: Telehealth (SMS texting) and Patient Payments.