Updox Inbox

Incident Report for Updox-Partners

Resolved

This incident has been resolved.
Posted Feb 02, 2026 - 21:01 EST

Identified

Our team has determined the cause of the service interruption within Updox and is working on a resolution. We will continue to post updates every 30 minutes. Thank you for your patience.
Posted Feb 02, 2026 - 20:50 EST

Investigating

Updox is experiencing a disruption in service. Users may be unable to load the items in their inbox, sent, or archive folders. We are investigating the issue and will post updates every 30 minutes.
Posted Feb 02, 2026 - 20:07 EST
This incident affected: Interface / Connection to Updox (Web User Interface).