Import to EHR, upload, and print
Incident Report for Updox-Partners
Resolved
This incident has been resolved.
Posted Oct 19, 2023 - 16:19 EDT
Investigating
Our technical operations team has identified an issue that is impacting the ability for some users to send to the EHR, upload, and print. You may also experience some general slowness in the web application. We are working to resolve the issue as quickly as possible. We apologize for any impact this causes to your business and will keep you updated on our progress.
Posted Oct 19, 2023 - 15:46 EDT
This incident affected: Interface / Connection to Updox (Web User Interface) and Import to EHR.