Direct Secure Messaging (DSM) Service Disruption

Incident Report for Updox-Partners

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 12:21 EDT

Identified

We are currently investigating an issue with our server hosting environment that is affecting the ability of some customers to send and receive Direct Secure Messages (DSM).

Our team is actively working with our hosting partners to resolve the issue and restore full DSM functionality as quickly as possible. We appreciate your patience and will provide updates as more information becomes available.
Posted Jun 23, 2025 - 11:11 EDT
This incident affected: Direct e-Mail Messaging.