Updox Corporate Office Power Outage
Incident Report for Updox-Partners
Resolved
Power has been restored to the Updox offices. The partner support team will continue to provide support via email and resume full support center channels tomorrow morning at 8:30 a.m. eastern time.
Posted May 13, 2019 - 17:10 EDT
Investigating
Partners,

The Updox corporate office is experiencing a power outage this afternoon. We are unable to service phone support requests at this time. Please email your issue to us at PartnerSupport@updox.com. One of our agents will review your case and reply as soon as possible.
Posted May 13, 2019 - 16:52 EDT
This incident affected: Updox Corporate Office.