AWS outage causing SMS and faxing Delays
Incident Report for Updox-Partners
Resolved
This incident has been resolved.
Posted Sep 29, 2022 - 09:23 EDT
Identified
We have been notified by our telecommunications provider that they are experiencing text message delivery delays and fax delays. They are addressing the issue and will keep us updated on their efforts. We apologize for any inconvenience this causes to your business and we will keep you updated on their progress.

For our Canadian customers this is affecting Canada as well for faxing.
Posted Sep 28, 2022 - 14:35 EDT
This incident affected: Faxing.