Inbound Faxing Delays
Incident Report for Updox-Partners
Resolved
This incident has been resolved.
Posted May 23, 2018 - 08:07 EDT
Monitoring
We are now processing faxes, but there may continue to be a delay as we work through the backlog.
Posted May 22, 2018 - 17:04 EDT
Investigating
We are currently experiencing a delay with inbound faxing.
Posted May 22, 2018 - 16:35 EDT
This incident affected: Faxing.